Order Tray | Contact Us | Home | SIG Lists

[aprssig] FW: APRS server data corruption

AE5PL Lists HamLists at ametx.com
Mon Apr 18 00:25:41 UTC 2005


Actually, this has nothing to do with Mic-E conversion.  It does have to
do with incorrect TNC settings.  The default settings for aprsD and the
KPC is to turn Filter ON.  This will mangle packets and is probably what
is causing this.  Have the IGate ensure that Filter is OFF.  As Steve
pointed out, the problem is not in the servers, rather it is in the
IGate.

A second known problem with the aprsD IGate is the handling of the DEL
character.  This problem is normally visible in western Europe where the
Mic-E packet will contain a DEL character because of the longitude.

73,

Pete Loveall AE5PL
mailto:pete at ae5pl.net  

> -----Original Message-----
> From: Steve Dimse
> Posted At: Sunday, April 17, 2005 3:27 PM
> Subject: Re: [aprssig] FW: APRS server data corruption
> 
> On Apr 17, 2005, at 4:14 PM, Andrew Rich wrote:
> 
> > Now I understand. Something is modifying the APRS pos report.
> >
> > APRSD was in the chain.
> 
> This comes up every year or so. Short answer, all IGate 
> programs at one point in time converted Mic-E reports into 
> "normal" APRS reports, and there were problems in the way 
> this was coded. (The conversion was done because of  the 
> erroneous belief that something in the APRS IS was eating 
> non-printing chars, when it turned out the problem was 
> actually an incorrect tnc setting.) This conversion has been 
> discouraged for many years, but is still seen at times in 
> people running old software. 
> It is not specific to aprsd.




More information about the aprssig mailing list