Order Tray | Contact Us | Home | SIG Lists

[aprssig] KISS, Linux, Minicom & a KPC 3+

Tapio Sokura oh2kku at iki.fi
Sun Feb 20 14:32:04 UTC 2005


Ryan Tourge wrote:
> I'm trying to get my KPC3+ out of KISS mode but nothing seems to be working.
> Being that it's 25 miles away I can't do a hard-reset. I've used minicom and
> tried sending [alt]192 [alt]255 [alt]192 per the manual but that doesn't do
> it. (It says offline in the status bar if that helps). I also tried echo
> "0xFF 0xC0 0xFF" > /dev/ttyS1 with several variations and that doesn't work.

You might want to make sure that no other program is using the serial 
port at the same time first and that the serial port settings are ok. If 
someone is using the serial port at the same time, command "fuser -v 
/dev/ttyS1" should display some information on the program. Something 
like "stty -F /dev/ttyS1 sane raw xxxxx", where xxxxx is the serial port 
speed of the TNC, should set some reasonable defaults for the serial 
port. Then send something like "echo -n -e '\300\377\300' >/dev/ttyS1". 
\300 is 0xC0 and \377 is 0xFF.

   Tapio




More information about the aprssig mailing list