Order Tray | Contact Us | Home | SIG Lists

[aprssig] Telemetry question

Alan P. Biddle APBIDDLE at UNITED.NET
Fri Aug 15 21:09:04 UTC 2008


Hi,

A while back, I had a question about getting telemetry to display in real
units.  Bob gave me a great example doing it by the URL on FINDU, and I have
pretty well gotten that working.  Thanks, Bob!

Now, I would like to find out how to upload the data over RF into the system
so that someone just going to a site such as APRS.FI will automatically see
the data without the complicated URL.  Here is an example of what I am
trying to do:

http://aprs.fi/telemetry/VK5RAC-1

I have asked about how to do that various places, and gotten answers such as
"you can do that in the beacon message" or "you broadcast the parameters
according to the APRS spec on RF," (Operator of APRS.FI.) or "you could do
that with my unit's scripting language."  (Which in the last case does not
yet exist.)   No doubt true, but not overly helpful if you don't really know
what you are doing.  Ahem.  

The only copy of the APRS spec covering telemetry I have found seems to be
part of the documentation of a piece of dedicated hardware Bob was selling a
few years ago, the MIM, dated 1999.  That is long before there was anything
like FINDU or APRS.FI.  The basic PARM, UNIT, etc formats are there, but the
data seems very specific to sending the data to a single unit.  And it is
unclear whether the formatting restrictions imposed by DOS apply to current
systems, and whether unused channels can simply be truncated, or whether
they need to be padded in some way.  ETC.

To be very specific, I have a Byonics TinyTrak4 and would, as a start, to be
able to display the supply voltage and temperature on APRS.FI in real units,
such as in the above examples.  It does display the raw data using the
defaults just fine.  I normally use UI-VIEW32 at home, and would like to be
able to do the configuring from the UNPROTO message system.  I have had no
problem sending and having it appear in the raw data at APRS.FI, but it is
not being recognized as the correct format to configure the telemetry.  I
have been sending TO APRS, one line at a time.

Rather than bore you with all the things which haven't worked, here is the
configuration data which I am trying to send.  It is truncated to the
minimum which is human readable, so is almost certainly wrong. I know that.

PARM.BATTERY,TEMP,,,,,,,,
UNIT.VOLTS,DEGC,,,,,,,,
EQNS.0,.109,0,0,1.96,-273,0,0,0,0,0,0,0,0,0
BITS.00000000,NOTHING HERE....

I have two items to display, and the rest are, at present, "don't care."  So
could someone who does know what they are doing give me the above, properly
formatted, to be used by UI-VIEW32, so that when I go to WA4SCA-8 I get
something like the example above?  I know that APRSDos has this built in,
but I really don't want to set up yet another program if I can avoid it.

Thanks in advance for any help on this.

Alan
WA4SCA




 






More information about the aprssig mailing list