Order Tray | Contact Us | Home | SIG Lists

[aprssig] KPC-3+ KISS mode delayed packet issue?

Tom Russo russo at bogodyn.org
Fri Dec 19 17:33:57 UTC 2008


I seem to recall reading here some time back that there was some bug in 
the KPC-3+ in KISS mode that could cause it to screw up and hold packets
for some reason.

I'm seeing some very strange delayed packets in my local environment, and
since I'm running a KPC-3+ in KISS mode I'm wondering if it's my fault.
What it seems to be is that packets I am transmitting seem to be getting
digipeated 10 minutes or more later.  My logs show my transmitted packet
going out to the TNC, then sometime soon after a digipeat of a much older 
packet coming back.  My current guess is that my packets are being held at my 
TNC until my next transmission or something (this rings a bell about the KPC 
holding until a buffer is full or something like that).  I want to fix it if 
that's what's going on.

Could someone refresh my memory about:
  1) what the actual issue is that can cause KPC-3+ KISS-mode TNCs to hold
     off transmitting packets for as much as 10 minutes, if there is in fact
     such an issue
  2) The correct way to fix it (is it as simple as power-cycling the TNC?)
  3) The best way to avoid the problem in the first place, if it is in fact
     my system that's causing the delay.

-- 
Tom Russo    KM5VY   SAR502   DM64ux          http://www.swcp.com/~russo/
Tijeras, NM  QRPL#1592 K2#398  SOC#236        http://kevan.org/brain.cgi?DDTNM
  In some cultures what I do would be considered normal. 
                                  -- Ineffective daily affirmation 



More information about the aprssig mailing list