Order Tray | Contact Us | Home | SIG Lists

[aprssig] KPC-3+ KISS mode delayed packet issue?

Curt, WE7U archer at eskimo.com
Fri Dec 19 18:24:46 UTC 2008


On Fri, 19 Dec 2008, Tom Russo wrote:

> It didn't jog my memory and doesn't seem to be the issue I'm having, but I
> called home and had the YL do a power-cycle on the TNC and the problem went
> away --- my digipeats are now all of the time-stamped packets that are going
> out *now*, instead of the time-stamped packet from 5-10 minutes
> ago.  So the problem was at my station and power cycling the TNC did clear it
> up, at least for now. But it took me a long time to notice the issue, and I'd
> like to avoid it in the future.

KD7NM near me has the same problem periodically.  Power-cycling the
TNC fixes it for him too.  He's running it in KISS mode with Xastir.
It's happened at least 2 or 3 times that I can recall, but seems to
take months to reappear.

It could be that a KISS frame END character gets missed or
corrupted, requiring a new KISS frame to come through to supply it,
but then that one gets stuck because of not enough framing
characters, awaiting the next packet to come through, etc.

It could also be a memory leak or counters overflowing and losing
track.  Could be all kinds of things.

-- 
Curt, WE7U.				archer at eskimo dot com
http://www.eskimo.com/~archer
   Lotto:  A tax on people who are bad at math. - unknown
Windows:  Microsoft's tax on computer illiterates. - WE7U.
The world DOES revolve around me:  I picked the coordinate system!"



More information about the aprssig mailing list