Order Tray | Contact Us | Home | SIG Lists

[aprssig] Xastir Internet->RF configuration

Greg D. ko6th_greg at hotmail.com
Tue Apr 7 05:50:24 UTC 2009


Hi all,


The K6FGA-1 "thing" apparently is both a digipeater and an Igate, and
(Doh!) there is a difference...  :-)  I don't have Xastir set up as a
digi, so what I'm getting appears to be correct.  Thanks for
(patiently) clarifying that.


Ha!  Curt, I think you were right about the desense, at least that's part of the problem.  I turned the DJ-580 down to low power, and took off the antenna from the D7, and I can get maybe one in 4 packets recognized.  But there still seemed be an audio quality problem, or maybe it's the Tx delay.  I tried editing the xastir.cnf file, changing the DEVICE0_TNC_TXDELAY: to 100; didn't seem to do much (*).  Then I tried putting more capacitance on the audio line going to the DJ-580, and that helped a lot.  I also lowered the PTT resistor value, to maybe get a more solid keying, and perhaps that helped a bit too.  I do notice that once in a while I'll get a really short packet - clearly not fully formed - but then the retry usually goes ok.  I even sent a couple of messages to the D7, and bleep! there they are.  But I wasn't getting an ack from the D7, even though I see and hear it being sent.  ACK!  a broken wire...  Ok, now it's working.

So, progress!  But, not all is well.  When I turned the DJ-580 back to full power, I get no packets on the D7.  My guess is that the Tx delay is still too low for the HT, but even when I set the delay (see * below) to 1000, it still doesn't like it.  Assuming that 1000 is a valid entry (that it's not being truncated or something), I think I'm at some limit somewhere in terms of keying, and this little HT is being pushed too far.  Any ideas?  Maybe I have a "need" for a new rig at the Swap in May...

Greg  KO6TH

(*) After a lot of frustration, I figured out that Xastir only reads the config file when it starts up, and it writes it back out when it exits!  So, if you want to edit the config file, you need to shut xastir down, edit it, then start it back up again.



> Date: Mon, 6 Apr 2009 08:21:28 -0700
> From: archer at eskimo.com
> To: aprssig at tapr.org
> Subject: Re: [aprssig] Xastir Internet->RF configuration
> 
> On Sun, 5 Apr 2009, Greg D. wrote:
> 
> > I am in a hole, but even so, the Igates are pretty widely spread
> > out here, and there is only one that can hear me - K6FGA-1, about
> > 23 mi to the north.
> 
> Igate or digi?
> 
> 
> > Anyway, I tried the suggestions, but I don't think the Tx side is
> > working right.  If I tell Xastir to "Transmit now", I see the
> > TNC's PTT LED come on, and I hear the usual braaap of a packet,
> > but my D7 doesn't display anything.  Shouldn't I see my Xastir
> > station show up?  I also tried sending a message to the D7 (which
> > is configured to automatically acknowledge it), but the D7 doesn't
> > do anything.  Is this an audio quality issue with the TNC,
> > perhaps?  Or, is it sending a packet that the D7 ignores?
> 
> Could be TXD or it could be that you're desensing the D7 when you
> transmit.
> 
> 
> > Also, if I send a position report from the D7, at a low enough
> > power that the real digis don't hear it, I see my D7 show up on
> > Xastir's map and on aprs.is, as usual.  But I don't hear it
> > repeated back out over the air (no PTT, no audio).  Is that
> > expected?   (I do hear it from K6FGA-1 when I crank up the power,
> > and get the re-assuring "My Position" display on the D7.)
> 
> That is expected.  Xastir is not normally set up to be a digi, but
> does have the capability to be a WIDE1-1 fill-in digi if need be.
> For that mode you must use either AGWPE or a TNC in KISS mode,
> otherwise you don't have control over the correct bits to effect a
> digipeat.
> 
> -- 
> Curt, WE7U.				archer at eskimo dot com
> http://www.eskimo.com/~archer
>    Lotto:  A tax on people who are bad at math. - unknown
> Windows:  Microsoft's tax on computer illiterates. - WE7U.
> The world DOES revolve around me:  I picked the coordinate system!"
> 
> _______________________________________________
> aprssig mailing list
> aprssig at tapr.org
> https://www.tapr.org/cgi-bin/mailman/listinfo/aprssig

_________________________________________________________________
Rediscover Hotmail®: Get e-mail storage that grows with you. 
http://windowslive.com/RediscoverHotmail?ocid=TXT_TAGLM_WL_HM_Rediscover_Storage1_042009
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.tapr.org/pipermail/aprssig/attachments/20090406/e74dbb75/attachment.htm>


More information about the aprssig mailing list