Order Tray | Contact Us | Home | SIG Lists

[aprssig] delayed packets

Michael Carey michaelcarey at internode.on.net
Wed Mar 10 20:26:02 UTC 2010


Hi Wes,
I've experienced delays in received packets using UIView with AGWPE and 
a Paccomm TNC.
When the TNC (using KISS) was directly connected it wasn't an issue, but 
I wanted to use AGWPE for other programs to share the TNC.

I saw the issue through www.aprs.fi, a raw packet display of my 
digipeaters would show many duplicate telemetry frames. It didn't happen 
all the time.
The symptoms were like yours, a received packet would decode, but not 
appear in UIView. After another APRS transmission was received, the 
missing delayed telemetry frame would make it through. If this was after 
the 30 sec dupe timer had elapsed, UIView would pass it to the internet 
where it would show up as a duplicate.

I tried different version of Paccomm firmware, even a standalone KISS 
EPROM... it might appear to be fixed, but the problem would always come 
back.
In the end, I stopped using AGWPE and the problem went away. I'm not 
blaming AGWPE, the problem might have been caused by something else, 
possible UIView.

Michael.
VK5ZEA

Wes Johnston, AI4PX wrote:
> Well, to bring up an old sore subject again.  I looked at my track 
> this morning on the way to work, and noticed 2 huck-a-bucks in my 
> trip.  Two delayed packets delivered to aprs IS out of sequence.  Each 
> of them hit different digipeaters but ended up entering aprs IS at the 
> same point n2zz-5 in Aiken.  They are running UIView over there.  Here 
> is (what seems to be ) another case of ui-view delaying packets.  And 
> yes, I know everyone will rush in offering alternatives like the DSL 
> modem might have issues or a digipeater could have delayed the packets 
> due to a stuck squelch etc etc.... but in the end, in each case I've 
> seen delayed packets it has _always_ involved UI-View.
>  
> What is so egregious about this is that I'm using a 2 minute beacon 
> rate and the packets are arriving 2minutes and 30 seconds late.  I 
> wonder if this is a memory leak / windows issue where UIview runs 
> slower and slower the longer it runs?  We never seem to get to the 
> bottom of this one though.
>  
> I researched this a few years ago with WW6JC in Columbia SC and found 
> that it was also UIview.  Now to be clear, I'm not picking on anyone, 
> I'm aggrivated about a program that so many people use that has a bug 
> and won't /can't be fixed.
>  
> The tracker in question is ai4px-9 tracked from 11:20UTC until 11:56UTC.
>
> -- 
> Wes
> ---
> God help those who do not help themselves.
> ------------------------------------------------------------------------
>
> _______________________________________________
> aprssig mailing list
> aprssig at tapr.org
> https://www.tapr.org/cgi-bin/mailman/listinfo/aprssig
>   




More information about the aprssig mailing list