Order Tray | Contact Us | Home | SIG Lists

[aprssig] KPC3+ induced errors

Stephen H. Smith wa8lmf2 at aol.com
Tue Mar 15 03:55:39 UTC 2011


  This just in from the CA_APRS Yahoo! list:


"

Attached is a post I made today on Lynn's APRSIS32 group:
----------------------------------------------------------------------
http://groups.yahoo.com/group/aprsisce/

Lynn,
I have been testing several KPC-3+'s trying to duplicate the known 3+ APRS I-Gate delay problem. N6VUD-2 I-Gate finally started delaying packets to IS. This happened after letting it run without any interruptions for about 5 days. It started delaying packets by about 2 minutes, after a few days up over 10 minutes. I have documented my findings, and it appears to be a buffer holding back in the 3+. I tested with APRSIS32 running AGW and the 3+ in KISS. Somehow the 3+ starts to buffer packets, probably within the MC68HC11F1 processor, since it was holding back over 50 packets. It then starts sending old stale packets as new packets were received in a FIFO fashion. I have a video of this, I will post it.

After documenting I wanted to see if a simple exit KISS, enter KISS from the Enables/Ports/KPC3+ would clear the delay. After un-checking the KPC-3+, then checking again It did clear up the delay problem.

Could a timed port reset macro be added? I would like to be able to have it exit KISS, then re-start KISS immediately. This could be done late at night, or every six hours.

I have been working with another I-Gate sysop that has the same problem, he is running javAPRSIGate, and has a timer that resets the power to the KPC-3+ every morning 5AM. It clears the delay, but sometimes starts delaying again after as little as 4 hours.

Alan:-)

To vote, please visit the following web page:
http://groups.yahoo.com/group/ca_aprs/surveys?id=2655572





More information about the aprssig mailing list