Order Tray | Contact Us | Home | SIG Lists

[aprssig] APRS data via perl-to-tnc

Lynn W. Deffenbaugh (Mr) ldeffenb at homeside.to
Thu Nov 24 18:14:45 UTC 2011


Perl may be enabling flow control on the port that your cable or Perl 
isn't providing.  Try tying RTS to CTS and DTR to DSR and CD on the 
computer AND TNC end of the cable.  I've had devices before that would 
not send out their data until they had their handshaking provided and 
software that wasn't asserting DTR and/or RTS.  Once I joyplugged 
(typically the device end of, but sometimes both ends of) the cable, 
communication magically flowed.  And yes, it would work with some 
software and not with others based on which signals the software was 
instructing the PC to provide.

Lynn (D) - KJ4ERJ - Author of APRSISCE for Windows Mobile and Win32

PS.  The joy-plug on the device end of the cable also works around some 
cheap USB to serial cables that may not actually provide the handshaking 
signals, or may provide them too low for detection by some devices.

On 11/24/2011 8:55 AM, Lee Bengston wrote:
> On Wed, Nov 23, 2011 at 7:55 PM, Shawn Stoddard<stoddard at pobox.com>  wrote:
>> Try \r instead. In most languages that is a return. Don't speak Perl.
>> --
> Yeah, \r is a carriage return in perl as well.  Have already tried
> both \r and \n with no luck.  Yesterday I installed ser2net and was
> able to telnet to the tnc that's on /dev/ttyUSB0.  Thinking I had it
> licked because I've written lots of perl scripts using Net::Telnet, I
> proceeded to beat my head against the wall because I still couldn't
> get the tnc to give me a prompt.  Next I tried the perl expect.pm
> module and spawned the same telnet client that had worked manually,
> but still no dice.  The common denominator to all of the attempts is
> perl.
>
> One clue - when I run a script that attempts to illicit 'EH?' or
> 'cmd:' by sending various characters, and then I connect manually
> immediately afterward, I get the expected responses to what the script
> sent.  It's as if when the script is running I only have one-way
> communication out the serial port.  Oh well, I've spent way too much
> time on something I though would be relatively simple.
>
> Lee - K5DAT
>
> _______________________________________________
> aprssig mailing list
> aprssig at tapr.org
> https://www.tapr.org/cgi-bin/mailman/listinfo/aprssig
>




More information about the aprssig mailing list