[aprssig] Gateway with Overlay in latest version

Heikki Hannikainen hessu at hes.iki.fi
Mon Dec 16 22:58:47 CST 2013


On Tue, Dec 17, 2013 at 5:54 AM, Andrew P. <andrewemt at hotmail.com> wrote:
>
> Looks like something strange is going on here. Your packets are being
> rejected, yet other I-gates using the I& (overlaid) symbol code are working
> on aprs.fi in my area.
>
> 2013-12-16 11:26:41 EST: *W3EOC-5
> <http://aprs.fi/?c=raw&limit=&call=W3EOC-5>*
> >APJI23,TCPIP*,qAC,W3EOC-J2:!3957.65NI07535.05W&javAPRSIgate -
> k3jse at coolioh.com
>
> On the other hand, those stations are using ! instead of = as the APRS
> message type code. Yet my own station (KA2DDO) is using = and getting away
> with it (of course, I'm not using an overlay).
>
>
> 2013-12-16 06:42:55 MST: *AC0VP-10
> <http://aprs.fi/?c=raw&limit=&call=AC0VP-10>*
> >APJYC1,TCPIP*,qAC,WE7U-F1:=3925.36Nl10525.39W&PHG2880/W2 Digi, IGate, Bailey, CO - 73's Mike -
> http://www.ac0vp.com *[Invalid symbol table or overlay]*
> Hessu, if you see this, can you tell me why Mike's packets are being
> rejected by aprs.fi but mine and W3EOC-5's aren't?
>

Mike's packet has a l (lower case L) as overlay. Overlays need to be be
numbers or upper-case letters. It's easier to debug these issues by looking
at the "hex dump" version of the raw packets list:

http://aprs.fi/?c=raw&call=AC0VP-10&limit=50&view=hex

It uses a monospace font that makes easier to distinquish between I and l,
but at least my display, makes l and 1 quite similar. Argh. Monospace font
that makes all of l 1 I different, anyone?

*2013-12-16 21:22:56 EET AC0VP-10
<http://aprs.fi/?c=raw&limit=&view=hex&call=AC0VP-10>: 124 bytes [Invalid
symbol table or overlay]*
0x00 A C 0 V P - 1 0 > A P J Y C 1 , T C P I P * , q A C , W E 7 U -
     41433056502d31303e41504a5943312c54435049502a2c7141432c574537552d
0x20 F 1 : = 3 9 2 5 . 3 6 N l 1 0 5 2 5 . 3 9 W & P H G 2 8 8 0 / W
     46313a3d333932352e33364e6c31303532352e33395726504847323838302f57
                             ^^^^

See the hex ASCII codes, 0x6c for l and 0x31 for 1. The hex mode can be
enabled using the drop-down thingy on the top of the display.

You could probably do the validity checking in YAAC too, to make the config
bug immediately obvious to users.

- Hessu
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.tapr.org/pipermail/aprssig/attachments/20131217/514ce8df/attachment.html>


More information about the aprssig mailing list