[aprssig] "no sym yet" icon + compressed packets?

Heikki Hannikainen hessu at hes.iki.fi
Sat Feb 15 01:40:18 CST 2014

On Sat, 15 Feb 2014, Stephen H. Smith wrote:

> On 2/14/2014 11:07 PM, Paul Bramscher wrote:
>> Forgot to add -- my station, and the others that get 'no sym yet', seem
>> to all be passing compressed-format packets.  So maybe that's a factor
>> also.  It's unclear to me how to turn off compression on my D710, as an
>> experiment, so see if that's his issue.
> 3)   Mic-E format is notorious for getting mangled by some out-dated igate 
> software that attempts to convert it to plain-text before passing it to the 
> APRS-Internet System.  (Rather than just passing the Mic-E packet as-is to 
> the APRS-IS.)
> Are the "raw packet" displays on findu or APRS.fi showing the typical Mic-E 
> gibberish, or are you seeing something that looks like plain-text lat/long 
> values in your igated packets?

The mic-e packets seem to be getting mangled. Some packets have

    symboltable: /
    symbolcode: -

/- is correct for the house.

Some packets with the 0x1C byte missing (mangled by broken igate) get 

    symboltable: ]
    symbolcode: -

which is quite invalid indeed.


The aprs.fi code that translates that to text ("House (HF antenna)") seems 
to be a bit buggy, it probably should say something like "invalid symbol 
table or overlay code".

The APRS packet code at this end also needs a bit of improvement in the 
handling of mangled mic-e packets, I think it should be able to get the 
symbol table right, since it is present in the remaining packet data. I'll 
look into it a bit later.

The K0GDI-6 igate should also be fixed to not eat bytes out from mic-e 

   - Hessu, of aprs.fi, now in London

More information about the aprssig mailing list