[aprssig] Dire Wolf 1.0 installs but doesn't decode.

Arno Verhoeven pe1icq at sharon.esrac.ele.tue.nl
Sun Jun 15 11:31:55 CDT 2014


Hi,

I've read good things about Direwolf so I gave it a try on a Raspberry 
Pi. Did a fresh install, followed instructions in Raspberry-Pi-APRS.pdf 
<http://home.comcast.net/%7Ewb2osz/Version%201.0/Raspberry-Pi-APRS.pdf>. 
All of the software install went smoothly. Direwolf starts, and I get an 
average of 4406700 samples per 100 seconds. It only misses a few samples 
so I guess that is OK.

     Past 100 seconds, 4406720 audio samples, 0 errors.


I use a cheap USB sound device. dmesg shows it as follows;

[    3.367735] usb 1-1.3: new full-speed USB device number 4 using dwc_otg
[    3.490205] usb 1-1.3: New USB device found, idVendor=0d8c, 
idProduct=000e
[    3.502585] usb 1-1.3: New USB device strings: Mfr=0, Product=1, 
SerialNumber=0
[    3.513410] usb 1-1.3: Product: Generic USB Audio Device
[    4.205013] udevd[156]: starting version 175
[    5.749012] cm109: Keymap for Komunikate KIP1000 phone loaded
[    5.874608] input: CM109 USB driver as 
/devices/platform/bcm2708_usb/usb1/1-1/1-1.3/1-1.3:1.3/input/input0
[    5.991682] usbcore: registered new interface driver cm109
[    6.247566] cm109: CM109 phone driver: 20080805 (C) Alfred E. Heggestad


In direwolf.conf I have;

	ADEVICE default:CARD=Device

arecord -L doesn't show any plughw devices, just the default, 
sysdefault, and a bunch of surround devices.

When I start Direwolf the LED on the USB sound device starts flashing, 
so far so good.

But I cannot get Direwolf to decode any packets. I've played around with 
input gain settings in alsamixer (made sure I selected the right audio 
device with F6). mic and capture device setting are at maximum or close 
to maximum, but still no luck.

Is there any tools like an oscilloscope or spectrum screen as with the 
old linux soundmodem?  Some sort of adjustment tool with user feedback 
would be nice. How else am I to know what is a correct level setting?

Help please!  I'd appreaciate any pointers in the right direction :)

73, PE1ICQ
Arno Verhoeven

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.tapr.org/pipermail/aprssig/attachments/20140615/76ac98d9/attachment.html>


More information about the aprssig mailing list