[aprssig] KPC3 Fix for Delayd Packets

Fred Hillhouse fmhillhouse at comcast.net
Tue Aug 15 14:26:05 CDT 2017


I found this on the APRS.FI blog. Maybe others can verify Matt’s results. If it is as simple as building the correct cable … 

 

Matt Ackerman <https://www.blogger.com/profile/07288273364619867465>  said... 

I was working with Kantronics support on this issue and I seem to have solved it by shorting the RTS and CTS pins together within my serial cable. (PINS 4/5 on DB25 and PINS 7/8 on DB9) I simply ran a jumper between the two. This appears to be an issue with how the APRS software and/or the AX.25 stack controls the RTS pin and shorting the RTS and CTS together prevents the software from holding the RTS pin low. If the RTS pin is at low voltage the KPC3+ will start buffering and does not get caught back up. I have been running mine for several weeks without showing this behavior again. Before I made the change it would happen after about 12 hours. 

July 16, 2012 at 8:57 PM  <http://blog.aprs.fi/2011/03/kantronics-kpc3-considered-harmful.html?showComment=1342461464554#c7869470599134569351> 

 

 

From: aprssig [mailto:aprssig-bounces at tapr.org] On Behalf Of Randy Love
Sent: Tuesday, August 15, 2017 1:14 PM
Cc: aprssig
Subject: Re: [aprssig] KPC3 Fix for Delayd Packets

 

I remember the exchange, but can't find them either.

 

There were two possible solutions, or combination of the two, that fixed it.

One was tying the DTS RTS lines together.

The other was disabling all flow control in the TNC settings.

 

There's much less headache from this if you use something other than a KPC3+ in kiss mode.

 

Randy

WF5X

 

On Tue, Aug 15, 2017 at 12:28 PM, John D. Hays <john at hays.org> wrote:

Doing a quick search, I cannot find a fix -- there was a reference to it being a buffer issue.  It seems that most people just move on to something that works.

 

 

On Sun, Aug 13, 2017 at 9:45 AM, Max Harper <kg4pid at yahoo.com> wrote:

Anyone here remember a post or a link to a webpage about fixng the KPC3 delayed packet problem when in kiss mode? It may not have been on this list. I have searched using Google and Yahoo and can't find what I'm looking for. The fix talked about the handshaking lines in the serial cable as well as a setting in the KPC3 and claimed it would fix the delayeing problem.

 

Thanks

Max KG4PID


_______________________________________________
aprssig mailing list
aprssig at tapr.org
http://www.tapr.org/mailman/listinfo/aprssig





 

-- 

 

  _____  

John D. Hays
Edmonds, WA

K7VE

 

  <http://k7ve.org/images/Facebook-26.png>    <https://docs.google.com/uc?export=download&id=0B16WvG35kZ7SUFYwZldBMmJXeWs&revid=0B16WvG35kZ7STXlkYm1oMkpHYzVxOUlxVEtXc1dqMXZhdjZFPQ>   <http://k7ve.org/blog>   <http://twitter.com/#!/john_hays> 

 


_______________________________________________
aprssig mailing list
aprssig at tapr.org
http://www.tapr.org/mailman/listinfo/aprssig

 



---
This email has been checked for viruses by Avast antivirus software.
https://www.avast.com/antivirus
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.tapr.org/pipermail/aprssig/attachments/20170815/84e2308b/attachment.html>


More information about the aprssig mailing list