[aprssig] KPC3 Fix for Delayd Packets

Pete Loveall AE5PL Lists hamlists at ametx.com
Wed Aug 16 09:18:40 CDT 2017


Unfortunately, Kantronics' claim that "the APRS software and/or the AX.25 stack controls the RTS pin" is inaccurate.  Most KISS mode interfaces do -not- use hardware flow control because it is specifically stated in the KISS specification to not use flow control, software or hardware.  Most KISS mode interfaces simply set RTS on and never change this.  If the KPC3+ has an issue with no flow control being used and therefore requires it to be implemented on their TNCs, they should say so.  I have seen the delayed packets through KPC3+ TNCs when the software is definitely setting RTS on and leaving it there so the stated fix will not work unless the KPC3+ is flow controlling itself.

It was determined this is an issue tied to all firmware versions of the Kantronics KPC3+ and no cabling change fully resolved the issue (unless, again, the KPC3+ has to control itself by pacing itself through its own CTS pin).  Remember, the delay is on -received- packets, not transmitted packets.

73,

Pete Loveall AE5PL
pete at ae5pl dot net

> -----Original Message-----
> From: Fred Hillhouse
> Sent: Tuesday, August 15, 2017 2:26 PM
> Subject: Re: [aprssig] KPC3 Fix for Delayd Packets
> 
> I found this on the APRS.FI blog. Maybe others can verify Matt’s results. If it is
> as simple as building the correct cable …
> 
> 
> 
> Matt Ackerman <https://www.blogger.com/profile/07288273364619867465>
> said...
> 
> I was working with Kantronics support on this issue and I seem to have solved it
> by shorting the RTS and CTS pins together within my serial cable. (PINS 4/5 on
> DB25 and PINS 7/8 on DB9) I simply ran a jumper between the two. This
> appears to be an issue with how the APRS software and/or the AX.25 stack
> controls the RTS pin and shorting the RTS and CTS together prevents the
> software from holding the RTS pin low. If the RTS pin is at low voltage the
> KPC3+ will start buffering and does not get caught back up. I have been running
> mine for several weeks without showing this behavior again. Before I made the
> change it would happen after about 12 hours.


More information about the aprssig mailing list