Order Tray | Contact Us | Home | SIG Lists

[wxsig] Still looking for solution :-(

Ken Brown Ken.A.Brown at noaa.gov
Thu Nov 16 13:29:50 UTC 2006


Will,

I had the same kind of hang at the same place with a X1W2 original
version sensor.  In my case the problem was a poor solder connection
between the humidity sensor and the one-wire device which was causing
unrealistic indication to be sent to the T-238.  I discovered the
problem by connecting the W1W2 directly to the computer and running
the one wire IButton-TMEX viewer.  Fixed solder connection and it
works fine.  I don't remember what the readings were.  It appears
the T-238 must not be able to handle an out of range value.  I think
Bill checked his W1W2 off line and it was OK.

Ken Brown

Will Beals wrote:
> Bill:
> 
> Hopefully we can figure something out that won't require drilling holes and
> venturing into crawlways!
> 
> Unfortunately your diagram didn't come out to well, can you elaborate in a
> different format?
> 
> T238 Controller 
> ?? Feet of cable
> Rain gauge
> ?? Feet of cable
> X1W2 sensor with humidity
> ?? Feet of cable
> Is there something more?
> 
> I'm not ruling out a SW bug (easier to fix than crawling rewiring), but
> would like to understand the setup enough to make sure that is where I
> should be heading.
> 
> On the lockup, a few more questions:
>   Does the LED continue flashing?
>   I understand you do not have a TNC, but which TNC mode is selected?
>   Can you hit the menu button to get back to menus or do you have to hit
> reset?
>   Can you measure the 1-wire bus voltage with a volt-meter with and without
> the humidity sensor attached?  If possible, read it with the T238 hung too.
> While running, the bus voltage will vary on a voltmeter, so max value is OK.
> 
> will
> 
> 
> 
> 
> -----Original Message-----
> From: Bill Hosking [mailto:hoskingb at earthlink.net] 
> Sent: Monday, November 13, 2006 7:59 PM
> To: will at beals5.com
> Cc: 'TAPR Weather Station SIG Mailing List'
> Subject: Re: [wxsig] Still looking for solution :-(
> 
> Ok, I am using standard flat, 4 wire phone cable, not twisted pair.
> 
> Not completely sure what you mean by 't' and everything  in-line.  where ">"
> 
> is a phone connector  and "|" is pc track, the x1w2 looks like this (only
> showing the 1wire line)
>                            wire                      x1w2        wire 
> temp/wind     wire        rain
> controller >  >-------------------> >------> >---------->  >------------>
>> -------> >-|
>                                                            |
>                                                     humidity
>                                                     sensor The >--> being
> the "pass through" connectors on each pwb. With that half-a__ pictorial,
> what is 'in line'.
> 
> The only way to shorten my run is to drill a new access for the phone cable
> and spend a couple of days in a tight crawlway. Temp, wind, and rain work
> fine with existing cable length. It is not until I 'turn on' the humidity
> sensor in the softare that it hangs up. Unfortunately at 66 yrs old, the
> humidity sensor doesn't win against the attic crawl.
> 
> Thanks for the help guys.
> 
> Bill
> 
> ----- Original Message -----
> From: "Will Beals" <will at beals5.com>
> To: "'Bill Hosking'" <hoskingb at earthlink.net>
> Cc: "'TAPR Weather Station SIG Mailing List'" <wxsig at lists.tapr.org>
> Sent: Monday, November 13, 2006 7:34 PM
> Subject: RE: [wxsig] Still looking for solution :-(
> 
> 
>> Bill:
>>
>> (adding in WXSIG again as this is useful information for others too)
>>
>> In looking at where you hanging, I didn't read your other answer closely
>> enough.  I had a 60-foot run at my first house (I've moved since) and it
>> worked, but only with some very basic non-twisted pair indoor telephone
>> cable.  Cat-3 or Cat-5 cable did not work at all.  Others have 
>> corroberated
>> this with similar problems and solutions.
>>
>> However, and more importantly, tee junctions have a very bad track record 
>> on
>> the 1-wire bus.  I know of several posts in the past years where folk had
>> such setups and were never able to get them to work until they went to
>> something that had everything inline.
>>
>> will
>>
>> -----Original Message-----
>> From: Bill Hosking [mailto:hoskingb at earthlink.net]
>> Sent: Sunday, November 12, 2006 10:36 PM
>> To: will at beals5.com
>> Subject: Fw: [wxsig] Still looking for solution :-(
>>
>> Thoughts will??
>>
>> Bill
>> ----- Original Message -----
>> From: "John Bennett" <jabennett at insightbb.com>
>> To: "Bill Hosking" <hoskingb at earthlink.net>
>> Sent: Sunday, November 12, 2006 8:42 PM
>> Subject: Re: [wxsig] Still looking for solution :-(
>>
>>
>>> Bill,
>>>
>>> You may be pushing the limit on cable length. I ran into a problem with
>>> reading the soil temp sensors I made. Turns out that the cable length
>>> had a great deal to do with it. In my server code, I use a modified
>>> version of the Dallas SDK - which is issued under the GPL - for the
>>> 1-wire interface. It's been awhile, but I seem to remember having to
>>> change something in the part that reads the 1-wire bus. Either I had to
>>> increase the settle time for the bus and/or increase the number of
>>> retries on the read. I did not experience this with shorter lengths of
>>> cable. It sounds like getting the -2 off your roof will be a real pain,
>>> but believe you've run out of options. I would get it on the bench with
>>> shorter cables. If that works, put a cable of the same length or longer
>>> on it and see if your problem returns.
>>>
>>> John
>>>
>>> On Sun, 2006-11-12 at 18:26 -0700, Bill Hosking wrote:
>>>> Re TNC, I have not been using a TNC, just the wx station by itself. And,
>>>> yes - it does 'setting up tnc' then goes to 'one moment please' and that
>>>> is
>>>> where it hangs. Could the absence of a tnc cause it to hang up with
>>>> humidity
>>>> selected but not with it deselected?
>>>>
>>>> For John, the run to the x1w2 is about 60 ft, the run on to the rest of
>>>> the
>>>> setup is another 15-20 ft.
>>>>
>>>> Bill
>>>> ----- Original Message ----- 
>>>> From: "Will Beals" <will at beals5.com>
>>>> To: "'TAPR Weather Station SIG Mailing List'" <wxsig at lists.tapr.org>
>>>> Sent: Sunday, November 12, 2006 6:07 PM
>>>> Subject: RE: [wxsig] Still looking for solution :-(
>>>>
>>>>
>>>>> Bill:
>>>>>
>>>>> Hmmm.  To the best of my knowledge there are no hardware differences
>>>>> between
>>>>> the T238 and T238+ other than the modem.  For talking on the 1-wire
>>>>> bus,
>>>>> they use the same code on the same micros.
>>>>>
>>>>> The T238 is still hanging up at the "One momemt please.." screen?
>>>>>
>>>>> Right after putting that text up that screen, the code goes and looks
>>>>> at
>>>>> your operating mode setting (TNC DIR, TNC-LTP, Peet,...) to decide how
>>>>> to
>>>>> initialize things.  Is there any chance you have picked "5-min avg
>>>>> (modem)"?
>>>>> If so, the software would be trying to talk to the modem which on a
>>>>> regular
>>>>> T238 is probably not hooked up.    If this is the case, go to the
>>>>> "UART/Display Options" menu and pick a better setting.  I am not sure
>>>>> of
>>>>> your TNC setup, so not sure what to suggest.
>>>>>
>>>>> Hope that helps, if not hopefully we'll get it in a few more
>>>>> iterations.
>>>>>
>>>>> will
>>>>>
>>>>>
>>>>> -----Original Message-----
>>>>> From: wxsig-bounces at lists.tapr.org
>>>>> [mailto:wxsig-bounces at lists.tapr.org]
>>>>> On
>>>>> Behalf Of Bill Hosking
>>>>> Sent: Sunday, November 12, 2006 2:18 PM
>>>>> To: Wx List @ TAPR
>>>>> Subject: [wxsig] Still looking for solution :-(
>>>>>
>>>>> The problem continues with no solution...
>>>>>
>>>>> Platform: original T238 board with T238+ rom, updated to 1.15.8R
>>>>> software
>>>>> 1-wire: Temperature, Wind speed/direction, rain, and now x1w2 outside
>>>>> humidity board.
>>>>> Voltage: I am running +5 up pin 1 of the cable (with appropriate
>>>>> jumpers)
>>>>>
>>>>> Problem: with system initalized and working (have temp,wind/rain
>>>>> readings),
>>>>> I go to the Sensor menu, bypass the existing setups, and set 'yes' on
>>>>> the
>>>>> humidity sensor, complete the sensor chain. Now when I get to the
>>>>> 'Display
>>>>> Current Data', it hangs there forever. Either reset or power down do
>>>>> the
>>>>> same. By removing the sensor cable, resetting, and telling the box to
>>>>> erase
>>>>> the humidity sensor, I can return to a functioning temp/wind/rain
>>>>> operation.
>>>>>
>>>>> Thanks to John Bennett, I have all the test utilities. So I tested
>>>>> using a
>>>>> home-brew version of John's adapter that is contained on the x1w1 
>>>>> board
>>>>> because you can't supply the 5V on the purchased adapter.
>>>>>
>>>>> testfnd: runs perfectly and displays the correct 1-wire interface
>>>>> codes.
>>>>>
>>>>> tsthumd:runs perfectly giving me a reasonable humidity and temperature
>>>>> reading and also reads 5V for the voltage. As an additional test, I
>>>>> took
>>>>> the
>>>>> 5V jumper off and the test reads back no humitity and 0.00V on the
>>>>> voltage
>>>>> reading which tells me the +5V is getting up to the box on the roof..
>>>>>
>>>>> This would seem to tell me that the wiring and supply voltage are all
>>>>> correct. Problem remains - the t238 still hangs up at display current
>>>>> data.
>>>>>
>>>>> To try one last thing, I went up on roof and pulled jumper on temp
>>>>> sensor
>>>>> on
>>>>> x1w2 board and retried in case there was a conflict between the two
>>>>> temp
>>>>> sensors. Result - no change.
>>>>>
>>>>> What I suspect is that the SW is hitting something it cannot deal with
>>>>> in
>>>>> spite of the fact that the tsthumd says all is ok but I am not a
>>>>> programmer
>>>>> so, even though the source code is available, it would be of little 
>>>>> use
>>>>> to
>>>>> me.
>>>>>
>>>>> So - unless someone has an idea (other than pulling down and re-wiring
>>>>> whole
>>>>> system), I'll probably just put the cover back on the humidity box and
>>>>> forget it.
>>>>>
>>>>> Any great ideas out there guys??? Is the original T238 board
>>>>> incompatable
>>>>> with the T238+ firmware some way??
>>>>>
>>>>> A frustrated Mr Bill
>>>>>




More information about the wxsig mailing list