Order Tray | Contact Us | Home | SIG Lists

[wxsig] Humidity and Pressure Sensor Support

William Beals will at beals5.com
Sun Feb 11 21:48:51 UTC 2007


John:

Is the issue that you can't discover the sensor during the setup phase?  If
so, that means that the T238 is not able to see the device ID of the
humidity sensor on the 1-wire network.  That is a different problem compared
than the calibration issues.

If the device is not showing up, do check the 1-wire bus voltage on the
debug screen, that will confirm/deny the bus is healthy.  If healthy, try
some simple stuff like short cables on your bench (if not already so).

will

-----Original Message-----
From: wxsig-bounces at lists.tapr.org [mailto:wxsig-bounces at lists.tapr.org] On
Behalf Of John Vause
Sent: Sunday, February 11, 2007 10:19 AM
To: TAPR Weather Station SIG Mailing List
Subject: Re: [wxsig] Humidity and Pressure Sensor Support

Can someone has the TAI8570 pressure sensor working with the T238 and
original Dallas wind sensor (wind dir/speed) and rain gauge please email me
how they did it.

I've upgraded my T238 to 1.15.8R firmware but it doesn't detect the TAI8570.

Thanks.
Clay Cottingham wrote:
> Phil -
> 
> I have the 8570 running and, as you said, had to re-wire it to make it
work.
> Thanks!
> 
> The spec sheet on it states that it has calibration data that needs to 
> be downloaded to the host and used to calculate true pressure. I 
> notice that it is reading 1.87 inches low compared to the local 
> airport. Are you having to correct for yours?
> 
> Thanks,
> Clay
> 
> -----Original Message-----
> From: wxsig-bounces at lists.tapr.org
> [mailto:wxsig-bounces at lists.tapr.org]On Behalf Of Phil Reid
> Sent: Sunday, February 13, 2005 11:09 PM
> To: TAPR Weather Station SIG Mailing List
> Subject: RE: [wxsig] Humidity and Pressure Sensor Support
> 
> 
> 
> Hello all,
> 
> Utilizing RJ-11 connectors, the one-wire bus should be as follows ....
> 
>  	pin 2	--	ground
>  	pin 3	--	1-wire data
>  	pin 4	--	1-wire ground
>  	pin 5	--	pwr +5 VDC
> 
> When I first assembled the TAI8515 ver. 2.0, with the T-238, it 
> required pin 2 to have power and pin 5 to be ground. I modified the 
> T-238 to match the TA8515. This was an error. I should have modified 
> the TAI8515 to match the T-238 which is layed out correctly for the
one-wire bus.
> 
> Acquiring the TAI8570 and putting it on the modified one-wire bus, I 
> got the same message Jerry received, and scratched my head for a 
> couple of hours.
> 
> I acquired the RJ-11 connection specifications for each device and I 
> realized what had taken place.
> 
> I returned the T-238 to its original design, and modified the TAI8515 
> to match.
> 
> I now have the T-238 with the latest firmware, supporting and powering 
> the TAI8570/Barometer, TAI8540/Humidity, TAI8585/Counter with rain 
> gauge, and a TAI8515/Anemometer, all on the one-wire bus.
> 
> 73's     phil/w7oze
> 
> 
> _______________________________________________
> wxsig mailing list
> wxsig at lists.tapr.org
> https://lists.tapr.org/cgi-bin/mailman/listinfo/wxsig
> 
> 
> 
> _______________________________________________
> wxsig mailing list
> wxsig at lists.tapr.org
> https://lists.tapr.org/cgi-bin/mailman/listinfo/wxsig
> 
> 
> 

-- 
* John Vause  KF4ERV  jdv at iglou_dot_com                *
* NOTE: email address altered for benefit of Spambots *
* My favorite law: The Law of Unintended Consequences *
*                         - John Vause                *
--

_______________________________________________
wxsig mailing list
wxsig at lists.tapr.org
https://lists.tapr.org/cgi-bin/mailman/listinfo/wxsig







More information about the wxsig mailing list