Order Tray | Contact Us | Home | SIG Lists

[wxsig] Connecting T-238+, X1W-1, X1W-2 and AAG

Leon Bruner leon at ljjf.net
Sun Jul 8 11:19:41 UTC 2007


I'm in the process of extending my initial weather staton that consisted 
of a T-238+ and an AAG weather station by adding the X1W-1 and X1W-2 and 
am having problems getting the system to work when the components are 
hooked together.  Here's my current situation:

1.  My T238+ and AAG WX station work well together:  I've had the 
station up and running - data have been seen on findu.
2.  I have completed assembly of the X1W-1 and it checks out OK using 
tstfind.
3.  I have attached the AAG WX station to thw X1W-1 and the sensors are 
found when tested using tstfind and other utilities.
4.  I have double checked the 1 wire cables I have made to ensure 
straight through and have good continuity

When I connect the T238+, X1W-1 and AAG together I either get bus shorts 
to ground, or the T238+ doesn't start when it is plugged in depending on 
configuration.  I have looked through the wxsig archives and seen 
references to the need to cut some traces on the AAG unit in order to 
make it all work, but haven't found clear direction on which traces to 
actually cut.

In trying to figure this out I've looked at the schematics of all 4 
units and have come up with the following table that describe the 
connections assigned to the various pins on RJ11 jacks.  I've put 
together 2 tables shown below that show the pin outs on the 1 wire bus 
for the four components used in the system.  One table shows the 
situation where P17 and JMP3 jumpers are placed across P and 2, and the 
other situation where the jumpers areplaced across P and 1.

Situation 1 

Pin Number**

	

Device**

*6 Pin RJ 11*

	

*4 Pin RJ 11*

	

*T-238+*

	

*X1W-1*

	

*X1W-2*

	

*AAG*

1

	

 

	

 

	

 

	

 

	

 

2

	

1

	

gnd

	

+5V

	

+5V

	

Vcc

3

	

2

	

Bus

	

Bus

	

Bus

	

Bus

4

	

3

	

gnd

	

gnd

	

gnd

	

gnd

5

	

4

	

+5V

	

 

	

 

	

gnd

6

	

 

	

 

	

 

	

 

	

 

X1W-1 P17 jumper connect pins P and 2
X1W-2 JMP3 jumper connect pins P and 2

Situation 2

Pin Number

	

Device

*6 Pin RJ 11*

	

*4 Pin RJ 11*

	

*T-238+*

	

*X1W-1*

	

*X1W-2*

	

*AAG*

1

	

 

	

 

	

 

	

 

	

 

2

	

1

	

gnd

	

 

	

 

	

Vcc

3

	

2

	

Bus

	

Bus

	

Bus

	

Bus

4

	

3

	

gnd

	

gnd

	

gnd

	

gnd

5

	

4

	

+5V

	

+5V

	

+5V

	

gnd

6

	

 

	

 

	

 

	

 

	

 

X1W-1 P17 jumper connect pins  P and 1
X1W-2 P JMP3 jumper connect pins P and 1

It's dangerous for a guy like me to be reading schematics because if 
there ever was an amateur looking at this stuff, it's me...  So I'd 
appreciate those of you who really know something about this to please 
check my work.  I used the schematics on the TAPR website for the T238+ 
and X1W units, and a schematic found on the AAG website for the pin-outs 
on the AAG WX station (aag schematic: 
http://www.aagelectronica.com/aag/en-us/p_1.html) .
<http://www.aagelectronica.com/aag/en-us/p_1.html>

Assuming that these tables are correct, then it seems to me the best way 
for me to connect all four units together is to do the following:

1.  Place jumpers on P17 and JMP3 across pins P and 1 as this will make 
the bus wiring for the T238+ and X1W units the same.
2.  Connect the T238 to the X1W-1 using a straight through 4 lead cable.
3.  Connect the X1W-2 to the X1W-1 using a straight through 4 lead cable.
4.  Connect the AAG WX station to the X1W-2 using a cable that crosses 
leads 1 and 4 so that +5 V from pin 4 of the X1W-2 will be directed to 
pin 1 of the AAG wx station.

Does this make sense?  If not, does anyone have an alternative 
recommendation? 

Thanks for the help.

Regards,

Leon
NT8B



More information about the wxsig mailing list