Order Tray | Contact Us | Home | SIG Lists

[wxsig] AAG Version 3.0 to T238

Rich Beckwith rjbeckwith at gmail.com
Mon Mar 30 02:34:29 UTC 2009


How does build quality etc. appear?  Any first impressions?

On Sun, Mar 29, 2009 at 9:29 PM, William Beals <will at beals5.com> wrote:

> Rich:
>
> Great on the cabling to resolve the sensor issues.
>
> Yes, I did receive the new AAG unit and have started some software work for
> it. I have a few questions into Aitor just to get some clarifications, so
> going pretty smoothly so far.
>
> will
>
> -----Original Message-----
> From: wxsig-bounces at tapr.org [mailto:wxsig-bounces at tapr.org] On Behalf Of
> Rich Beckwith
>  Sent: Sunday, March 29, 2009 8:24 PM
> To: TAPR Weather Station SIG Mailing List
> Subject: Re: [wxsig] AAG Version 3.0 to T238
>
> Will,
>
> For follow up:
>
> I changed the cabling so that both devices, the T238 and OpenTracker+
> supplied V+ to the AAG unit.
>
>
> As far as the problem with the serial port, it only occurs when using a USB
> to Serial adapter.  "Regular" serial ports don't seem to have the problem
> so
> I will assume the issue is either with USB/Serial adapters or this brand.
>
> Thanks for the tips.
>
> Have you receive the new AAG unit yet?
>
> Rich
>
> On Sun, Mar 29, 2009 at 4:32 PM, Rich Beckwith <rjbeckwith at gmail.com>
> wrote:
>
> > Will,
> >
> > Here is what I discovered:
> >
> > With the jumper in place the I can read temperature but not wind
> > direction.
> >
> > Without the jumper I can read wind direction, but not temperature.
> >
> > As far as the serial port goes, I might try a 3 wire or 2 wire cable in
> > instead of a standard cable and see if that helps.
> >
> > For now, it looks like I will have to have to provde V+ to get both
> > temperature and wind direction.
> >
> > Rich - wn0x
> >
> >
> >
> > On Sun, Mar 29, 2009 at 4:25 PM, William Beals <will at beals5.com> wrote:
> >
> >> Rich:
> >>
> >> OK on wind sensor working now, chalk it up to a mystery solved for
> reasons
> >> unknown!
> >>
> >> For the display dimming, are you talking about the backlight or the
> >> characters?
> >>
> >> If it is the backlight, then be worried!  That means the 12V supply is
> >> getting dragged down enough affect the backlight brightness.  It takes a
> >> lot
> >> of power to do that, so something is likely getting damaged.
> >>
> >> If it is the LCD characters that are dimming, that is likely a heavy
> load
> >> on
> >> the RS-232 data lines on your PC, suggestive of a cross-wired signal.
> The
> >> LCD module needs a negative supply, so I cheat (a little) by borrowing
> the
> >> -9V the MAX232 generates for RS-232 signals and run it to the negative
> >> supply for the LCD.  This usually works pretty good, your report is the
> >> first I've heard of where there has been an interaction.  Well, at least
> >> the
> >> first person that has told me anyway.  The PC isn't supposed to provide
> >> much
> >> of a load to those lines, but the MAX-232 doesn't provide much current
> >> either.  I only drive one line, the Tx line, so unless you have a short
> >> somewhere to a neighboring pin, it should be hard to drag down that
> line.
> >> That is where I'd poke around and see if you see something strange.
> >>
> >> will
> >>
> >> -----Original Message-----
> >> From: wxsig-bounces at tapr.org [mailto:wxsig-bounces at tapr.org] On Behalf
> Of
> >> Rich Beckwith
> >> Sent: Sunday, March 29, 2009 3:09 PM
> >> To: TAPR Weather Station SIG Mailing List
> >>  Subject: Re: [wxsig] AAG Version 3.0 to T238
> >>
> >> Thats what's wierd.  The calibration worked just fine.  The AAG V3 unit
> is
> >> the only sensor connected to the T238.
> >>
> >> It would really simplify things if I didn't have to power the AAG sensor
> >> to
> >> get wind direction.
> >>
> >> I'll keep experimenting and let you know.
> >>
> >> BTW - I noticed when I plug a computer into the unit to use the PC for
> >> data
> >> logging the display dims to the point where I can't read it very well.
> >>  The
> >> computer is attached with a standard serial cable to a USB serial
> adapter.
> >> Unplug from the computer and the display is visible again.
> >>
> >> Ideas?
> >>
> >> Rich - wn0x
> >>
> >> On Sun, Mar 29, 2009 at 3:40 PM, William Beals <will at beals5.com> wrote:
> >>
> >> > Rich:
> >> >
> >> > The T238(s) should work just fine with the AAG V3 weather station.
> >> > Calibrating is much easier than with the earlier V2 and Dallas weather
> >> > stations as the T238 does not need to discover an array of IDs.  When
> >> you
> >> > perform the calibration, you should be asked to disconnect any other
> >> > potential conflicting sensors that have the same 1-wire ID.  Once you
> do
> >> > that, it should just recognize the ID, then ask you to point north.
> >> >
> >> > That is what *should* happen, what happens when you try to do a wind
> >> > direction calibration?
> >> >
> >> > will
> >> >
> >> > -----Original Message-----
> >> > From: wxsig-bounces at tapr.org [mailto:wxsig-bounces at tapr.org] On
> Behalf
> >> Of
> >> > Rich Beckwith
> >> > Sent: Sunday, March 29, 2009 1:06 PM
> >> > To: TAPR Weather Station SIG Mailing List
> >> > Subject: [wxsig] AAG Version 3.0 to T238
> >> >
> >> > Colleagues,
> >> >
> >> > I have a AAG version 3 weather station that will read wind direction
> >> fine
> >> > with my OpenTracker Plus, but when connected to the T238 (not plus)
> will
> >> > read temperature and wind speed but not wind direction.  Sensor setup
> >> seems
> >> > to work fine.  Any suggestions?  Do I have to supply 5 volts to the
> AAG
> >> > version 3.0 unit and remove the temperature jumper?
> >> >
> >> > Thanks,
> >> >
> >> > Rich - wn0x
> >> > _______________________________________________
> >> > wxsig mailing list
> >> > wxsig at tapr.org
> >> > https://www.tapr.org/cgi-bin/mailman/listinfo/wxsig
> >> >
> >> >
> >> > _______________________________________________
> >> > wxsig mailing list
> >> > wxsig at tapr.org
> >> > https://www.tapr.org/cgi-bin/mailman/listinfo/wxsig
> >> >
> >> _______________________________________________
> >> wxsig mailing list
> >> wxsig at tapr.org
> >> https://www.tapr.org/cgi-bin/mailman/listinfo/wxsig
> >>
> >>
> >> _______________________________________________
> >> wxsig mailing list
> >> wxsig at tapr.org
> >> https://www.tapr.org/cgi-bin/mailman/listinfo/wxsig
> >>
> >
> >
> _______________________________________________
> wxsig mailing list
> wxsig at tapr.org
> https://www.tapr.org/cgi-bin/mailman/listinfo/wxsig
>
>
> _______________________________________________
> wxsig mailing list
> wxsig at tapr.org
> https://www.tapr.org/cgi-bin/mailman/listinfo/wxsig
>


More information about the wxsig mailing list