Order Tray | Contact Us | Home | SIG Lists

[wxsig] (Fixed) Ds1994 issue onewire viewer shotscreens

Pedro Motilla pedrolo2 at pedrolo.com
Wed Sep 8 13:28:32 UTC 2010


I am very sorry for the delay on answering you¡¡¡¡ :-(

It works perfectly. The message appears, gets very clear. I do think, it
makes clearer for user that it is "working".

Perfect,

Thanks again Will

If you need any further assisance, just let me know.

I am gathering the parts for building barometer and humidity sensors.
When I finish it, I will comment it.

Best Regards.

Pedro.

El dom, 05-09-2010 a las 13:51 -0600, William Beals escribió:
> Pedro:
> 
> Attached is a tweak to the code to show the "wait a moment" message to show up at a better time.  When you get a chance, let me know if it works OK.  It's OK to reply to the reflector, I'm sending it to you directly just because the reflector has issues with attachments.
> 
> will
> 
> -----Original Message-----
> From: wxsig-bounces at tapr.org [mailto:wxsig-bounces at tapr.org] On Behalf Of Pedro Motilla
> Sent: Sunday, August 15, 2010 3:01 PM
> To: TAPR Weather Station SIG Mailing List
> Subject: Re: [wxsig] (Fixed) Ds1994 issue onewire viewer shotscreens
> 
> Yes���
> 
> That's right. Just tested now. Works nice and fast.
> 
> Could be the "Gathering data" or something like this could help anxious
> users like me. hi hi.
> 
> I did some emphasis on "maybe a bug" because I did not know if it was a
> bug or a "timing" issue, but really it's a bug ... on the user� (myself
> hi hi hi).
> 
> If you need some test on new version, just let me know. I still do not
> have implemented many sensors, but working on it.
> 
> Congratulations Will, nice version.
> 
> EA5BFT.
> Pedro.
> 
> 
> 
> El dom, 15-08-2010 a las 12:01 -0600, William Beals escribi�:
> > Pedro:
> > 
> > Very neat to see the video, that helped a LOT!
> > 
> > What the software is doing to confuse you is that when you are in the menus and see the "display current data", you do need to hit select to start the process.  You do that, but there is a 5-10 second delay from when you press the button before I start to display anything.  That is because the software needs time to go get the first round of data.  The problem is that I show nothing on the screen during that time so you don't know that I've acknowledged you pressing the select key.  What I need to do is put up a "wait a moment" message as soon as you press select so you know what is going on.  I thought I had that at some point, I'll go look at the code.  I guess I'm so used to knowing what is going on that I haven't noticed it.  That, by the way is also why there is such a long delay from the "got the time" message until you see the first data.
> > 
> > I will add that to the formal 1.16.2 firmware release.
> > 
> > will
> > 
> > -----Original Message-----
> > From: wxsig-bounces at tapr.org [mailto:wxsig-bounces at tapr.org] On Behalf Of Pedro Motilla
> > Sent: Sunday, August 15, 2010 11:37 AM
> > To: TAPR Weather Station SIG Mailing List
> > Subject: Re: [wxsig] (Fixed) Ds1994 issue onewire viewer shotscreens
> > 
> > Hi will, better than explain how it works, is that you can SEE and hear
> > how it works.
> > 
> > http://www.youtube.com/watch?v=bqDtfAwvmI8
> > 
> > follow the link and you can see the new sw release in action.
> > 
> > In general, i think it works properly.
> > 
> > I only see "maybe" a bug, and it is that when you push the menu button
> > and make a "complete round" it says on the screen Display current data,
> > but nothing happens. You have to play with several buttons in order it
> > to show anything (usually shows "today stats", when it shows "today
> > stats" you have to press, several times "select" button until you can
> > see the current data.
> > 
> > The rest, works properly.
> > 
> > Let me know if you want any other test, I will make it and video record
> > it for you.
> > 
> > Thanks. 
> > 
> > EA5BFT
> > Pedro.
> > 
> > El s?b, 14-08-2010 a las 07:41 -0600, William Beals escribi?:
> > > (Wxsig folk, I accidently replied to Pedro only last night, so a few more entries in the email thread)
> > > (Also, my original reply got nabbed to because the attachment was too big, so here is the text only
> > > 
> > > Pedro:
> > > 
> > > No problem, the change is pretty quick. I'll send the object code file to you directly as it is too big to post to the reflector.  It is a variation on the release I have pending for DS1904 support anyway.  If you confirm all the rest of the functions work, I will go ahead and post it in release form to the website.
> > > 
> > > will
> > > 
> > > -----Original Message-----
> > > From: Pedro Motilla [mailto:pedrolo2 at pedrolo.com]
> > > Sent: Saturday, August 14, 2010 4:35 AM
> > > To: William Beals
> > > Subject: RE: [wxsig] Ds1994 issue onewire viewer shotscreens
> > > 
> > > Hi Will!!!!!!!!!!!!!!
> > > 
> > > That's great    
> > > 
> > > Finally a human explanation for this extrange happenings ;-) hi hi hi
> > > 
> > > For sure this makes sense      
> > > 
> > > I would appreciate very much if you do so, but i do not want to stole your time. If it is time consuming, just let it run. If it is something easy and fast, I would test the can, and if it has something broken, I would discard it and order a new 1904 unit.
> > > 
> > > As I tell, i do not want to stole your time.
> > > 
> > > I tried to find on the code the string 0x04 just to see if I could guess how it works, but i did not find that string, i found 0x0?? on several asm files, but 0x04, I could not. Sorry I do not have any knowledge of programing.
> > > 
> > > Thanks in advance.
> > > 
> > > Very best regards from EA5BFT, Pedro.
> > > 
> > > El vie, 13-08-2010 a las 18:28 -0600, William Beals escribi :
> > > > Pedro:
> > > > 
> > > > I did my research this evening to refresh my memory on this.  The last byte of the ID is what is called the Family Code.  For a DS1994 that is supposed to be 0x04.  That is what I use as a trigger to know there is a DS1994 on the bus.  Your DS1994 has a family ID of 0x84 which I am not recognizing.  With a little more digging that is the family id of the DS2404, the actual time keeping chip that makes up the heart of the DS1994 can!  That would explain why the iButton viewer recognizes it as it lists the DS2404 as an alternate part number.  Putting a few things together, I suspect it is indeed a bad part and whatever programming they do to the chip to change it from the DS2404 ID to a DS1994 ID is broken. 
> > > > 
> > > > At least that is finally a story that I think makes sense!
> > > > 
> > > > If you like, I can create a test code cut to recognize the 0x84 ID to see, but if that can already has something broken, it may be a better idea to get a new DS1904.
> > > > 
> > > > will
> > > > 
> > > > -----Original Message-----
> > > > From: pedrolo2 at pedrolo.com [mailto:pedrolo2 at pedrolo.com]
> > > > Sent: Friday, August 13, 2010 2:02 AM
> > > > To: William Beals
> > > > Subject: Re: [wxsig] Ds1994 issue onewire viewer shotscreens
> > > > 
> > > > Hi Will, I DO THINK that this could be the key to strange happenings.
> > > > 
> > > > I ordered the can from Canadian suplier, but was very hard to find 
> > > > anybody who could sell this part. Maybe this can comes from a "second"
> > > > manufacturing batch and have a different address. I am also running 
> > > > out of ideas, so the can had been transferred to "uncompleted 
> > > > projects's box", I took it back just to make this tests.
> > > > 
> > > > For sure that (unless we can solve the issue) I will purchase a new
> > > > DS1904 part.
> > > > 
> > > > Thanks again for your time and effort.
> > > > 
> > > > Best Regards.
> > > > 
> > > > EA5BFT
> > > > Pedro.
> > > > 
> > > > William Beals <will at beals5.com> ha escrito:
> > > > 
> > > > > Pedro:
> > > > >
> > > > > Rev 1.16.1 software does support the DS1994, so I'm running out of   
> > > > > ideas.  The fact it works with a PC makes that a pretty   
> > > > > hard-to-believe answer.  A reversed polarity usually does give the   
> > > > > "shorted to ground" message, so you did have it right the first   
> > > > > time.  That also verifies that you are making OK contact by seeing   
> > > > > that short!
> > > > >
> > > > > I went back and looked at your pictures of the 1-wire viewer and   
> > > > > something does not look right there, I am expecting a family ID of   
> > > > > 0x24 for the DS1994 and I don't see it in the screenshots.  I   
> > > > > finally have the 1-wire viewer running on my Win7 machine (long   
> > > > > effort!!), so let me go look at a DS1994 to see what I see.  I think  
> > > > >  this may be an issue or simply that the new viewer software may be   
> > > > > doing something I don't understand.  I will look this weekend and   
> > > > > let you know.
> > > > >
> > > > > I have a candidate 1.16.2 software version to support the DS1904, so  
> > > > > if you do get a part before I publish it formally, just let me know  
> > > > > and I will send it to you.
> > > > >
> > > > > will
> > > > >
> > > > >
> > > > > -----Original Message-----
> > > > > From: wxsig-bounces at tapr.org [mailto:wxsig-bounces at tapr.org] On   
> > > > > Behalf Of Pedro Motilla
> > > > > Sent: Thursday, August 12, 2010 2:29 PM
> > > > > To: TAPR Weather Station SIG Mailing List
> > > > > Subject: Re: [wxsig] Ds1994 issue onewire viewer shotscreens
> > > > >
> > > > > Hi will, nice to hear from you.
> > > > >
> > > > > Hope your basement works are going on good track.
> > > > >
> > > > > Well i can not explain what is going on:
> > > > >
> > > > > Software is discarded as it is 1.16.1 Version, so it is pretty new.
> > > > >
> > > > > Contact with the can, i used a wooden clip to hold the wires, now I 
> > > > > holded it on my hand making pressure with fingers.
> > > > >
> > > > > I measured voltage and it shows 4.95 Volts. so it sounds ok.
> > > > >
> > > > > Just in case I had changed polarity, I reversed the can, and the 
> > > > > station shows a mistake "1-wire device error or short to ground" 
> > > > > (maybe not exactly this but, quite similar.
> > > > >
> > > > > So the only thing i can think is a defective can. But, in that case, 
> > > > > why it "looks like" it work on computer program???
> > > > >
> > > > > Maybe I order a new DS1904 part...
> > > > >
> > > > > Could the ds1994 use a internal battery for any purpose? could this 
> > > > > battery be runned out??
> > > > >
> > > > > I do not understand. Thanks for answering Will.
> > > > >
> > > > > Best regards.
> > > > >
> > > > > Pedro.
> > > > >
> > > > > El vie, 06-08-2010 a las 21:11 -0600, William Beals escribi?:
> > > > >> Pedro:
> > > > >>
> > > > >> As you can tell, catching up!
> > > > >>
> > > > >> The screen shots for the DS1994 all look OK, so it very much looks   
> > > > >> like the DS1994 itself is OK.  I double-checked the datasheet for   
> > > > >> the DS1994 and the can and flange (the part without the etching) is  
> > > > >>  ground and the part with the part numbers and such is the signal   
> > > > >> part, so you do have it wired up correctly.  A simple check to   
> > > > >> ensure all is OK is put a voltmeter on the can when you have it   
> > > > >> connected.  You should see something pretty close to +5V on the   
> > > > >> printed part since the communications are narrow pulses.
> > > > >>
> > > > >> Are you sure you are making good contact with the can.  It is   
> > > > >> stainless steel so the can had better not corrode, but not sure   
> > > > >> about what connection methods you are using.
> > > > >>
> > > > >> Final question, what revision software are you using?  DS1994   
> > > > >> support was added in Rev 1.10.0, so quite a while ago.
> > > > >>
> > > > >> will
> > > > >>
> > > > >> -----Original Message-----
> > > > >> From: wxsig-bounces at tapr.org [mailto:wxsig-bounces at tapr.org] On   
> > > > >> Behalf Of Pedro Motilla
> > > > >> Sent: Saturday, May 22, 2010 5:46 AM
> > > > >> To: wxsig at tapr.org
> > > > >> Subject: [wxsig] Ds1994 issue onewire viewer shotscreens
> > > > >>
> > > > >> I have updated software, checked wiring, contacts... so the only   
> > > > >> thing i think is a 1994 defective part?
> > > > >>
> > > > >> I enclose the shotscreen from onewire viewer, just in case anybody   
> > > > >> can check his own 1994 and see if there is any difference, which   
> > > > >> could explain why it does not comunicate.
> > > > >>
> > > > >> Thanks.
> > > > >>
> > > > >> Pedro.
> > > > >>
> > > > >>
> > > > >> _______________________________________________
> > > > >> wxsig mailing list
> > > > >> wxsig at tapr.org
> > > > >> https://www.tapr.org/cgi-bin/mailman/listinfo/wxsig
> > > > >
> > > > >
> > > > >
> > > > > _______________________________________________
> > > > > wxsig mailing list
> > > > > wxsig at tapr.org
> > > > > https://www.tapr.org/cgi-bin/mailman/listinfo/wxsig
> > > > >
> > > > >
> > > > > _______________________________________________
> > > > > wxsig mailing list
> > > > > wxsig at tapr.org
> > > > > https://www.tapr.org/cgi-bin/mailman/listinfo/wxsig
> > > > >
> > > > 
> > > > 
> > > > 
> > > > 
> > > 
> > > 
> > > 
> > > 
> > > _______________________________________________
> > > wxsig mailing list
> > > wxsig at tapr.org
> > > https://www.tapr.org/cgi-bin/mailman/listinfo/wxsig
> > 
> > 
> > 
> > _______________________________________________
> > wxsig mailing list
> > wxsig at tapr.org
> > https://www.tapr.org/cgi-bin/mailman/listinfo/wxsig
> > 
> > 
> > _______________________________________________
> > wxsig mailing list
> > wxsig at tapr.org
> > https://www.tapr.org/cgi-bin/mailman/listinfo/wxsig
> 
> 
> 
> _______________________________________________
> wxsig mailing list
> wxsig at tapr.org
> https://www.tapr.org/cgi-bin/mailman/listinfo/wxsig





More information about the wxsig mailing list